1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Them's Fightin' Herds is now out on Early Access!
    You can buy it from these links.
    Humble Bundle // Steam

  3. 26.6.18: Situation update

    Current Early Access Patch: 7-22-2018 + Hotfix: 7-21-2018.a

Chests in Salt Mines give an error?

Discussion in 'Bug Reports' started by Snivian Moon, Feb 22, 2018.

  1. Snivian Moon

    Snivian Moon How I mine for combo?
    Backers' Beta Tester

    Messages:
    28
    Likes Received:
    92
    Whenever I open a costed chest in the salt mines, and the reward is not food of some sort, I get the following error: "Some kinda server error. The server cannot give you any items..."

    I'm not sure if this is a legit error, or just something I'm doing wrong, but since it declared itself an error I thought I would post it here. Sorry if that's wrong! But thanks for any help or explanation.

    20180222200244_1.jpg
     
    Delusional Dreamer likes this.
  2. beta

    beta Mane6 Dev
    Staff Member Mane6 Developer

    Messages:
    406
    Likes Received:
    805
    Thank you. I might know what this is. Looking into it.

    The screenshot is SUPER helpful by the way.
     
  3. Snivian Moon

    Snivian Moon How I mine for combo?
    Backers' Beta Tester

    Messages:
    28
    Likes Received:
    92
    Thanks so much for your hard work! I know you guys are really putting in some long hours, but I just want to say it's really appreciated.

    Loving everything about the game so far! You should be SUPER proud of what you've made.
     
    Delusional Dreamer and Redness like this.
  4. beta

    beta Mane6 Dev
    Staff Member Mane6 Developer

    Messages:
    406
    Likes Received:
    805
    glad to help:arismile2:
     
  5. BananaMeteor

    BananaMeteor Backers' Beta Tester
    Backers' Beta Tester

    Messages:
    9
    Likes Received:
    16
    I also had this same problem! Chests took my salt without producing any sort of item. Sucked cause I was doing a run with a friend and he kept getting neat accessory drops. Hope it's fixed soon!
     
    Delusional Dreamer likes this.
  6. Pom d'or

    Pom d'or Gave himself a fake award
    Backers' Beta Tester

    Messages:
    117
    Likes Received:
    185
    I was hosting a pixel lobby overnight last night, for the first time.
    The little log you get when you host is full off odd messages I don't understand and which are probably meant for debugging, but one of them was something like "missing (something something): you won't be able to grant items to players."
    I tried to screenshot the log but my computer froze when I tried to take the screen shot so I just restarted (there were 0 players at that time anyway), and so I don't have the exact phrase. Sounds like it might be related though.
     
  7. BypenThynDragon

    BypenThynDragon I for one welcom our new ruler Smugdeer
    Backers' Beta Tester

    Messages:
    545
    Likes Received:
    842
    I was experiencing the same problome but it only occurred at the AhHHHHHH level[​IMG]
     
    Delusional Dreamer likes this.
  8. Delusional Dreamer

    Delusional Dreamer FÅ“num iCloud

    Messages:
    256
    Likes Received:
    771
    Can confirm this! Was there with him, and I've made a gif below of me opening one of these chests and getting the error. It strangely seemed to only happen to the 40 salt chests, every one before was fine and the issue only began when we hit AAAAAAAAAAAAAA.


    P.S. Sorry for any problems with the gif, I'm still not the best at recording things, but hopefully it'll still be helpful.
     
    #8 Delusional Dreamer, Mar 2, 2018
    Last edited: Mar 3, 2018
    BypenThynDragon likes this.
  9. beta

    beta Mane6 Dev
    Staff Member Mane6 Developer

    Messages:
    406
    Likes Received:
    805
    Saltmines getting a big rework soon. I'm taking a look at errors like these now.