• Them's Fightin' Herds is available now on Steam for Windows and Linux!
    You can buy it from these links:
    Humble Bundle // Steam

  • Current Game Version

    2.1.1 (5.21.2021)

Cannot launch the game successfully

CobaltSketch

Shanty/Oleander Main
May 8, 2021
3
0
• Location of Bug: App launch (via steam, exe directly, shortcut, big picture, etc.)

• Description:
After selecting 'Play' via steam, or double clicking the exe directly, a transparent window appears that the game usually displays in, after a brief moment, and a windows error sound effect, the app either closes immediately (screenshot1) or displays an error box (screenshot 2)

• Screenshot:
file Screenshot1.png illustrates what usually happens,
file Screenshot2.png showcases an occasional popup that vanishes before I can make it out in most cases, I've managed to hold it here long enough to get a successful screenshot

• Steps to reproduce:
1. click 'start' in steam / double click exe
2. error occurs

• Reproduction rate: 100% now, but this problem hadn't occurred as early as 3 days ago.

• Notes:

Previous unsuccessful fix attempts:
• Uninstallation and reinstallation of TFH (as well as other affected games)
• Verify integrity of game files via steam
• Reinstall modern directX files, as well as the June2010 variant
• Reinstall Nvidia drivers, both Game-ready and Studio, several times
• Update windows normally
• Use the DISM windows command to repair windows update
• uninstall and reinstall windows C++ 2015, 2017, and 2015-2019
• restart PC between each attempt on all of these
• launch with both -logging and -verbose_graphics to no avail other than a terminal window launching alongside the game (shown in Screenshot 1)
• attempt to contact Oleander directly via means of dark magic (just resulted in a busy signal)

(not sure if this helps whatsoever, but in the interest of providing context, I'll include it)
This error extends to certain other games as well, including Skullgirls, Sonic Mania, and Sonic Adventure. However I'm running a known-good GTX1080, and even while this issue has persisted, it runs modern games such as Doom(2016), and the Spyro Reignited Trilogy on the highest settings without so much as a frame stutter.

I've already scoured these forums for info, including the October 14th 2020 post by SkyeWyvern, and followed the suggestions there as closely as I could manage, to no avail

If this is totally out of the depth of this forum, I understand completely, and appreciate the time taken to look into it regardless. Either way, love the game, and looking forward to playing it again, so I can finally learn all the ins and outs of Shanty.
 

Attachments

CamTSB

僕は誰なんだろう?
Mane6 QA
Feb 2, 2016
483
496
30
Ontario, Canada
twitter.com
Hmm. This is definitely extremely odd. The second screenshot screams that you don't have the right DirectX stuff installed since that'd be 9.0c, but you even mentioned the June 2010 stuff specifically and that's what it should be. This isn't a laptop so it's likely not anything to do with having the incorrect GPU chosen.

This does seem to be a bit out of our reach here, since it seems to be purely hardware related and it's not just us that isn't working... There were a couple little videos (one specifically for Skullgirls) that I found while taking a look around for stuff relating to the Screenshot2 error message, but it's likely very old and I wouldn't be able to say in confidence if it would work or not.

You may want to ask around with Skullgirls people at some point, just because they've been around longer and I can almost guarantee that someone there has run into the same issue at one point or another. It's... definitely concerning to me that this only started a few days ago. That has some alarms going, and I'm a bit concerned that something might be dying on your GPU, but I obviously can't prove anything. If these games worked before on the same setup then that's about the only thing I can think of.

I'm sorry that there wasn't much help to find here, I really am. If you DO find something that solves this, I'd really like it if you posted here again to let me know, just so I can satisfy my own curiosity and maybe add the fix to my list of things.
 

CobaltSketch

Shanty/Oleander Main
May 8, 2021
3
0
Thanks for listening to
Hmm. This is definitely extremely odd. The second screenshot screams that you don't have the right DirectX stuff installed since that'd be 9.0c, but you even mentioned the June 2010 stuff specifically and that's what it should be. This isn't a laptop so it's likely not anything to do with having the incorrect GPU chosen.

This does seem to be a bit out of our reach here, since it seems to be purely hardware related and it's not just us that isn't working... There were a couple little videos (one specifically for Skullgirls) that I found while taking a look around for stuff relating to the Screenshot2 error message, but it's likely very old and I wouldn't be able to say in confidence if it would work or not.

You may want to ask around with Skullgirls people at some point, just because they've been around longer and I can almost guarantee that someone there has run into the same issue at one point or another. It's... definitely concerning to me that this only started a few days ago. That has some alarms going, and I'm a bit concerned that something might be dying on your GPU, but I obviously can't prove anything. If these games worked before on the same setup then that's about the only thing I can think of.

I'm sorry that there wasn't much help to find here, I really am. If you DO find something that solves this, I'd really like it if you posted here again to let me know, just so I can satisfy my own curiosity and maybe add the fix to my list of things.
All of my attempts to resolve the issue had no avail, and I ended up using Windows' reset tool on the C drive. Thankfully that seems to have resolved the issue entirely, though it's unfortunate that I had to go to such a length.

Thanks for being so willing to tackle such a bugbear of an issue!

Now to get back to learning Shanty combos, and making some fanart!
 

CamTSB

僕は誰なんだろう?
Mane6 QA
Feb 2, 2016
483
496
30
Ontario, Canada
twitter.com
That is REALLY weird. I'm wondering if a windows update bodied you or a GPU driver got corrupted in the process. Hmm. Glad that it's sorted at the very least.
 

CobaltSketch

Shanty/Oleander Main
May 8, 2021
3
0
That is REALLY weird. I'm wondering if a windows update bodied you or a GPU driver got corrupted in the process. Hmm. Glad that it's sorted at the very least.
It's definitely unusual. I hadn't messed with anything out of the ordinary between the game working and having to reset stuff.

In the interest of thoroughness, I had run numerous malware scans using Sophos home, forced Windows update, rolled them back, and did a clean Uninstaller and reinstall of the NVIDIA drivers after writing the first post, eventually using Windows' built-in 'reset Windows' feature.

Just in case anyone else somehow runs into this issue and stumbles across this post, you can get to it by holding shift then clicking restart, and it should be an option in that menu. You can also keep your files, which is what I did.

Thanks again!
 
Top