1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Them's Fightin' Herds is now out on Early Access!
    You can buy it from these links.
    Humble Bundle // Steam

  3. Current Early Access Patch: 1-4-2019

AI option for dummy stops working after combo trials

Discussion in 'Bug Reports' started by Tribble, Mar 19, 2018.

  1. Tribble

    Tribble Backers' Beta Tester
    Backers' Beta Tester

    Messages:
    121
    Likes Received:
    208
    • Location of Bug: Training Mode

    • Description: If you set the dummy action to AI after having been in combo trials, it won't do anything. Exiting training mode and entering again will fix this.

    • Screenshot: --

    • Steps to reproduce:

    1. Go into training mode
    2. Set dummy action to AI, enjoy being beaten by the dummy
    3. Go into combo trials and do a combo
    4. Disable combo training
    5. Dummy is now inactive, despite dummy action still being set to AI. No matter how often you switch now between the different actions, the other actions will work but AI won't do anything.
    6. Leave training mode and enter again to get your punch-happy dummy back

    • Reproduction rate: 100%
     

    Attached Files:

  2. Cyberfox VII

    Cyberfox VII Backers' Beta Tester
    Backers' Beta Tester

    Messages:
    42
    Likes Received:
    298
    Can confirm. Though, my observation is that this only happens if the AI was enabled at any time during the Training Mode session, before the combo trial starts or restarts. I've found that I can turn on the AI after or even during the combo trial and have it work fine, but if I then start a combo trial or have it auto-restart, then it breaks until I restart Training Mode.
     

    Attached Files:

  3. beta

    beta Mane6 Dev
    Staff Member Mane6 Developer

    Messages:
    406
    Likes Received:
    808
    Checking into it
     
    Delusional Dreamer likes this.
  4. Leoloom

    Leoloom New Member

    Messages:
    1
    Likes Received:
    0
    I would like to inform that creating a save state in manual, then changing it to AI mode in training and reloading the save state will create the same AI issue.