• Them's Fightin' Herds is available now on Steam for PC!
    You can buy it from these links:
    Humble Bundle // Steam

  • Current Game Version

    1.4.2 (10.20.2020)

Search results

  1. Lurk

    Announcer Bug?

    When in a Vs match, the Announcer tends to interrupt the character intros, which can lead to Velvet's mouth moving, but nothing coming out.
  2. Lurk

    Of Arizona and the Salt Mines

    What exactly about the Salt Mines makes Arizona less than ideal to use? Is it the enemy AI or is it on the character end of things?
  3. Lurk

    Salt Mines Music Bug

    When I encounter one of the predators, as I go through a doorway, it will go to the fight screen, but without music. Sound effects will play as normal, though.
  4. Lurk

    A Non-Bug Palette Issue

    I ran into an issue earlier in the salt mines when I ran into one of the AI main characters. They happened to be the same character as I was playing and unfortunately the same palette, which led to some confusion. I’m guessing that AI will be tinted in the near future when this kind of matchup...
  5. Lurk

    Steam Inventory Issue

    While in a pixel lobby, I keep getting notifications that an item has been added to my inventory, but I only see a blank when I check.
  6. Lurk

    TFH at MagFest '19?

    This could also go in the South, because it's a Virginia/Maryland/DC area event. It's basically a Gaming & Gaming Music convention held the first weekend in January at National Harbor, Maryland. I'm hoping the game can get some representation there.
  7. Lurk

    Of Intros and Practice Mode

    Any chance enabling character intros in Practice mode could be an option? Sorry if it already is and I just haven't found it.
  8. Lurk

    Missing Title Screen Music

    Sorry if this has been addressed before, but the Title theme isn't currently playing anywhere in the game. Title screen is currently playing the Main Menu music. I'm not sure if this is deliberate or not.
  9. Lurk

    Disabled AI Match

    Is the AI Match being disabled a bug or is that coming with 1.0, too?
Top